Excel
CelinaLOVE
7

Wie Kodiere ich Zahlen bei Excel um? Hallo, vielleicht kann mir ja jemand mit meinem Problem helfen. Ich werte für ein Projekt einen Lebensqualtitätsfragebogen aus. Die Probandinnen können eine Antwort zwischen ja, trifft zu (eintspricht einer 5) und nein, trifft nicht zu (entspricht 1) ankreuzen. Für die Auswertung müssen mehrere Fragen addiert werden, dafür behalten einige der Fragen ihre zahl, bei anderen muss rekodiert werden (aus 5 wird 1, aus 4-2, aus 3-3, aus 2-4 und aus1 wird 5). Gibt es eine möglichkeit bei excel eine fomel einzusetzen, die bei diesen fragen automatisch umrechnet? Sprich: Wenn ich eine 2 eingebe automatisch eine 4 schreibt, bei einer 1 eine 5 usw.? das wäre extrem hifreich, weil ich dann nur die Antworten eintippen müsste und Excel für mich umrechnen würde. Ich hoffe ich konnte mein Problem halbwegs verständlich schildern :) Grüße aus Köln, Aleksandra

+0
(6) Antworten
Liptonicetea6

Warum so kompliziert? Umkodieren: in Spalte A stehen Werte von 1 bis 5, in Spalte B steht (in B1) =6-a1. Die Formel in alle betreffenden Zellen kopieren. Werte behalten: in B1 steht =A1 usw.

mameli

das ist in Excel ganz einfach: A1=5 B1=4 C1=3 D1=2 E1=1 immer umkodieren geht so: schreibe in A2=-A1+6 und kopiere die Formel nach rechts bis E2 . A1 nur umkodieren, wenn z.B. in Zelle A4 ein Kodier-Trigger steht, geht so: schreibe in =WENN(A4;-A1+6;A1) und kopiere die Formel nach rechts bis E2 Fertig!

Raetselblock

Wieso tippst Du nicht erst alle Ergebnisse ein und rekodierst dann mit Bearbeiten/Ersetzen. Zur Not mit einem Zwischenschritt, bei dem man zuerst 1 z.B. AAA zuweist, 2 - BBB, etc. Im zweiten Gang dann AAA durch 5 ersetzen, BBB durch 4, etc.

Legoview

Hallo ich habe nur OpenOffice hier funzt die Formel: =WENN(A1=2;"4";WENN(A1=5;"1"; WENN(A1=1;"5";WENN(A1=4;"2")))) Noch fehlende Zahlen in diese Formel ergänzen. Formel kommt in eine andere Spalte außer A was Du in A einträgst wird dann in der mit Formel umgewandelt. Beziehungsweise müsstest Du A1 durch deine gewünschte Spalte ersetzen. Dann nach unten kopieren dann steht in der nächsten Zeile anstatt A1 neu A2 etc. Da sich beide Programme sehr ähnlich sind sollte es klappen. Wenn nicht hast Du zumindest eine Anregung wie es klappen könnte. Ich hoffe ich konnte helfen! Schöne Grüße

Emir0301

Ich könnte das wahrscheinlich hinbekommen, aber ehrlich gesagt, ist es mir für dieses Forum viel zu kompliziert. Du mußt jedenfalls mit mehreren Spalten arbeiten, in denen die Daten der Eingabespalte geändert werden. Oder Makros benutzen.

sa2007

Am einfachsten ist es =(Feld-6)*-1 zu benutzen. da: (5-6)-1= 1 (4-6)-1= 2 usw.

Antwort hinzufügen